Valentina closes when creating details on 64 bit systems.

Issue #662 resolved
mil sv created an issue


I just updated Valentina, and when I opened it I was super happy to see so many new features ! But the problem is... When I opened the last pattern I was working on, I saw that all the details I created in the previous version were "wonky" . So I deleted them and tried to create new ones. I marked all the points and curves then pressed the "enter" touch, then cliqued "ok" (didn't had much choice) and the program closed itself immediately. Tried to do that several times with the same result.

I tried creating new points and some basic things and it works fine, apparently only the detail is a problem.

I'll go back to the previous version if I can do that, but I'd let you know as I don't know if this is a known issue or not, or maybe if I did something wrong will updating Valentina.

  • Opening Valentina via the terminal has the same effect.

  • This is what Valentina-version tells me :

valentina --version Checked locale: "fr_FR" Valentina

  • Pattern file and measurment file in attachment if needed.

  • If that helps this is what apt-cache policy tells me :

valentina: Installé : 0.4.999+57+201704101522~ubuntu16.04.1 Candidat : 0.4.999+57+201704101522~ubuntu16.04.1 Table de version : *** 0.4.999+57+201704101522~ubuntu16.04.1 500 500 xenial/main amd64 Packages 100 /var/lib/dpkg/status 0.4.5-1~ubuntu16.04.1 500 500 xenial/main amd64 Packages

Comments (17)

  1. mil sv reporter

    Ok !

    Now I have a different problem, sorry about that it's totally my fault, but I don't know how to fix this. I removed the "new" Valentina, then tried to reinstall a previous version. I didn't worked, only got me the new, so I removed all the Valentina repositories I had that may cause conflicts, then added the regular ppa ( dismine/valentina) then installed Valentina.

    But the version I now have ( is older than the one I was working on and my pattern files won't open . I have the message :

    "Erreur de fichier.

    Exception: Version non valide. La version maximale supportée est 0.2.4"

    But my patterns are using the 0.3.8 version...

    Could you tell me how can I fix that ? I'm really sorry...

  2. Roman Telezhynskyi repo owner

    Could you tell me how can I fix that ? I'm really sorry...

    You cannot fix this. There is no backward compatibility. Older Valentina versions can't open new pattern versions.

    You should wait fix.

  3. Roman Telezhynskyi repo owner

    @milsv, the bug should be resolved. Wait Monday and update to new test build.

  4. Roman Telezhynskyi repo owner

    When I opened the last pattern I was working on, I saw that all the details I created in the previous version were "wonky" .

    @milsv, can you send me that file? This shouldn't happen.

  5. mil sv reporter

    It's the same file that is attached to the conversation. Maybe "wonky" was not the proper word to use : I mean that the seams allowances were not drawn as they were in the previous version. I don't remember exactly what it looks like, but it was like if I did not used the corrects points to make them. But they did look "normal" , just not was I had in the previous version - if that makes sense !

  6. mil sv reporter

    I opened the file and the details that were not correct are deleted - I think I must have saved the file after deletting them. I opened the same pattern in another size in wich I had not deleted the details, and the problem was that the lines I had left "opened" in the previous version are not completely closed.

    I tried creating details in the latest version on Windows ( It's on the same computer that I use but it does not crash on windows but it does crash with ubuntu ) so the "wonky" seams allowances looks like I did not use "0" seams allowances before a point, but left them at the "current seams allowances" after . I'll attach the file and measurment file if you want to see.

    So I don't think it's a bug, just a rectification I have to make on the details when I'll use the new test build.

  7. Log in to comment