Cannot create a database, fails with a violation error every time

Create issue
Issue #274 closed
Former user created an issue

Clean install of 4.1.1 and trying to create a database with Mame .241 and get the attached error. Tried it on 2 different computers, anti virus software disabled and it is the same error using the latest XML file from MAME's site or trying to create from the Mame.exe.

Comments (9)

  1. Nebular Nerd

    Created an account to say I have this exact error myself on both 4.1.1 and 4.2.0 beta2 with both .241 exe and xml and .240 exe. Datutil reports various errors (although I cannot find it’s logfile) and creating a mame.xml produces the same results. Retroarch also does not seem to like the latest .xml so it could be a mame bug not a romcenter bug. EDIT: This and #267 appear to be the same bug

  2. Nebular Nerd

    I was digging around as I was looking for an Arcade only dat and found Arcade. It’s basically what MAME used to be with just the Arcade stuff and none of the MESS or ‘Mechanical’ games. Romcenter 4.2.0 Beta2 can build a valid .xml from the lastest Arcade .241, this points to the issue being in the full MAME .xml, maybe there is a buggy MESS driver or something that is causing the fail.

  3. Nebular Nerd

    No problems, as a test while looking for how to make my own custom .xml's, I’ve just checked a nightly build from Ashura-X (26/02/2022-16:21- MAME™ ver 0.241 - GCC ver. 11.2.0) which appears to be a complete 0.241 build with MESS etc... Romcenter 4.2.0 Beta 2 can build a dat without issue from this.

  4. Eric Bole-Feysot repo owner

    I tried to load from a mame 241 (64b) and it works, no errors (romcenter 4.2 beta2 in my dev environment).

    Can you zip and post the faulty database rdt file ? I can redo the loading from this file.
    Thanks

  5. Nebular Nerd

    Hi Eric,

    Well that’s just plain weird, I redownloaded mame0241b_64bit.exe as I had deleted the previous one, unpacked it new folder and pointed Romcenter 4.2.0 Beta 2 at it and it created a dat just fine, that’s very strange…… It feels almost like the version of MAME on the site has been quietly updated, even RetroArch is happily building a playlist off mame0241lx.zip where it refused to do so before. It’s a shame I deleted the original download from before I joined the thread as we could have taken a comparison of size/crc to see if it had changed.

    Given both this thread and #267’s originally creators have left the forums we cannot ask them for their input, I suggest we mark this as closed/one of those things and I’ll let you know if it happens again (and provide more info).

  6. Log in to comment