Update requirements documentation for Cactus

Create issue
Issue #1738 open
Ian Hinder created an issue

The Cactus User Guide has a section "Required software" which lists the software needed for Cactus. I think this should list the various language versions which are needed. For example, we could say (if this is the case) that Cactus requires C99 and C++98 or later. The page probably also should be updated to replace SVN with Git.

Keyword: documentation

Comments (3)

  1. Roland Haas
    • removed comment
    • Cactus requires C99 (since ET_2012_11 http://einsteintoolkit.org/about/releases/ET_2012_11_announcement.php)
    • Cactus requires a C++ compiler (since it's main() is in a C++ file)
    • Cactus (flesh and Cactus* arrangements other than tests, examples and the Fortran thorn) do not require any Fortran compiler
    • Einstein Toolkit requires Fortran 2003 (since LoopControl does #1546)
    • Carpet requires a Fortran 90 compiler
    • Carpet requires a C++98 compiler and STL and can use a C++11 compiler
  2. Log in to comment