Compile error in Ubuntu

Create issue
Issue #2371 resolved
Jason Kodish created an issue

/home/,,/einstein/Cactus/configs/sim/build/EOS_Omni/nuc_eos_cxx/readtable_cactus_wrapper.cc:5:10: fatal error: cctk_Arguments_Checked.h: No such file or directory
#include "cctk_Arguments_Checked.h"
^~~~~~
compilation terminated.
/home/../einstein/Cactus/configs/sim/config-data/make.config.rules:278: recipe for target 'readtable_cactus_wrapper.cc.o' failed
make[3]: *** [readtable_cactus_wrapper.cc.o] Error 1
/home/../einstein/Cactus/lib/make/make.thornlib:112: recipe for target 'nuc_eos_cxx/make.checked' failed
make[2]: *** [nuc_eos_cxx/make.checked] Error 2

The file cctk_Arguments_Checked.hh does not even exist so the compile crashes. I have no idea how to fix this. I followed the steps on the build page.

Comments (6)

  1. Roland Haas

    Hello Jason,

    it seems your are using the “master” version of at least the EOS_Omni thorn. This version cannot be mixed with “realease” versions of Cactus / Carpet right now. You will have to use either “master” for everything or a release version for everything. Using all master the code compiles fine for me.

  2. Jason Kodish reporter

    Thanks for the reply. I deleted the entire folder and started the build using the instructions found here: https://docs.einsteintoolkit.org/et-docs/Simplified_Tutorial_for_New_Users

    Now I get a new compile error

    Creating /home/cenobyte/einstein/Cactus/configs/sim/lib/libthorn_CarpetLib.a
    Makefile:256: recipe for target 'sim' failed
    make: *** [sim] Error 2

    I tried a second time and got the same error. Are there any instructions I can follow to get the right version? The instructions on those pages don’t work.

    Any ideas?

  3. Roland Haas

    Please do not use this tutorial. As the warning at the top of it says this tutorial has not (and will not be) updated for the "Proca" (2019_03) release of the Einstein Toolkit and the instructions provided here will fail if using ET_2019_03 instead of ET_2018_09. Please use either the online tutorial or the offline version of the tutorial notebook which will be kept up to date.

  4. Jason Kodish reporter

    Thanks for all the help! I finally got it to compile. Still having other problems though. Ran the hello world test script.

    Now getting this problem.

    Compiled under a user account and run under the same account

    Fatal error in PMPI_Comm_rank: Invalid communicator, error stack:
    PMPI_Comm_rank(110): MPI_Comm_rank(comm=0xbea6dd00, rank=0x7fff7de80158) failed
    PMPI_Comm_rank(68).: Invalid communicator
    [unset]: write_line error; fd=-1 buf=:cmd=abort exitcode=336153861
    system msg for write_line failure : Bad file descriptor
    Sun Apr 26 17:32:36 MDT 2020
    Simfactory Done at date: 0

    This is what I ran:

    ./simfactory/bin/sim create-run helloworld \
    --parfile arrangements/CactusExamples/HelloWorld/par/HelloWorld.par

  5. Log in to comment