SpeedCrunch doesn't get focus when launched

Create issue
Issue #302 duplicate
Former user created an issue

Originally reported on Google Code with ID 302 ``` What steps will reproduce the problem? 1. Set up MS keyboard to launch Speedcrunch on Calculator button press instead of the default application (using MS Intellitype Pro v7.0).

What is the expected output? What do you see instead? Expected output: Launches in foreground, assumes keyboard focus. Instead, Speedcrunch launches behind other windows. If no other windows are open, it still doesn't get focus (window must be clicked before typing).

What version of the product are you using? On what operating system? Speedcrunch v0.10.1 on Vista Ultimate x64. ```

Reported by `seanbob` on 2009-08-06 04:42:55

Comments (8)

  1. Former user Account Deleted

    ``` On further thought, may be a software bug with Microsoft's Intellitype software or keyboard driver and not SpeedCrunch. ```

    Reported by `seanbob` on 2009-08-09 04:21:42

  2. Former user Account Deleted

    ``` Hi Sean. I think it's not related to SC indeed, since it works fine on all Vista machines I've tried (launching normally, no calculator button). I'm closing this,

    but please let me know if you reach evidence that the issue is in SC instead. ```

    Reported by `helder.pereira.correia` on 2009-08-10 10:56:18 - Status changed: `Rejected`

  3. Former user Account Deleted

    ``` I've been having this bug for almost a year and I'm not even on Windows. Right now I'm on Ubuntu Linux 9.10 and using that same 0.10.1 Speedcrunch. Hope this is not too hard to fix, Speedcrunch is my favorite calculator. ```

    Reported by `waldir.leoncio` on 2009-12-21 17:39:07

  4. Former user Account Deleted

    ``` Is it possible to reopen this issue, considering my message above? ```

    Reported by `waldir.leoncio` on 2009-12-21 17:40:06

  5. Former user Account Deleted

    ``` Reopening since I can finally reproduce it (only on Ubuntu though), and even with latest code. ```

    Reported by `helder.pereira.correia` on 2010-01-27 21:11:46 - Status changed: `Accepted`

  6. Former user Account Deleted

    ``` Muito obrigado, Helder! I was starting to feel frustrated for not finding anyone else that had that problem. This has been bugging me for ages, and no matter what I do (upgrade, format and reinstall entire OS, whatever), it's always there.

    BTW, I can also second that SpeedCrunch 0.10.1 on Vista works fine. ```

    Reported by `waldir.leoncio` on 2010-01-28 11:31:56

  7. Former user Account Deleted

    Reported by `helder.pereira.correia` on 2010-03-11 22:25:07 - Status changed: `Duplicate` - Merged into: #282

  8. Log in to comment