Lost symbols for wrapped messages

Issue #135 resolved
Karagy
created an issue

Screenshots and savefile in attach.

All in windowed mode.

  1. Look at wolverine (to south from hero).

For: 1024x768, font 8x8

"An allied frightened badly wounded Companion wolverine named Izzy (9/33 7/7)"

For: 1024x768, font 12x16

"An allied frightened badly wounded Companion wolverine named Izzy (9/"
"   7/7)"
  1. Look to boa (to south-west from hero).

For: 1024x768, font 8x8

"An allied peaceful hiding frightened badly wounded boa constrictor (7/25 4/4)"

For: 1024x768, font 12x16

"An allied peaceful hiding frightened badly wounded boa constrictor (7"
"  5 4/4"

First two symbols in secont line always blank.

Comments (3)

  1. Karagy reporter

    Technically, that two spaces printed from here:

    // src\Term.cpp:2000:
                Write(0, 1, "  ");
    

    I do not see any easy solutions. It makes sense to leave it as is, defer to rework the whole TextTerm::EffectPrompt().

  2. RMTEW FULL NAME repo owner

    This should be a simple fix. Just do away with the hard coding of line numbers to print each data on.

    int16 cy0 = cy, wcy = cy - activeWin->Top;
    PRINT_NAME("%s");
    MAYBE_PRINT_LIFESIGHT(" (%d/%d %d/%d)");
    if (cy - cy0 == wcy)
        Write(0, ++wcy, "  ");
    else {
        Write(" <11> <7> ");
        wcy += cy - cy0;
    }
    PRINT_RIDING_WIELDING("%s")
    if (cy - cy0 == wcy)
        Write(0, ++wcy, "  ");
    else {
        Write(" <11> <7> ");
        wcy += cy - cy0;
    }
    PRINT_SEEN_WITH("%s");
    
  3. Log in to comment