Group not renamed

Create issue
Issue #1 closed
Daniel Rocha created an issue

Hello,

I tried to rename a group on Jira instance and it didn’t work. I couldn’t recognize what’s the problem, because I was able to rename some groups, but with some of them it didn’t work. I tried to identify if it was related to the number of members or with the numbers of projects associated, but I wasn’t able to detect what could be happening. We checked the log from JIRA, but nothing appears (our level log is set to WARN).

We are using Jira Software 8.7.1 and Jira Core 8.7.1.

Official response

Comments (15)

  1. Roma Bubyakin

    Hi Daniel,

    Thank you for opening a ticket!

    May I ask you to increase log level and then reproduce issue?

    • {base_url}/secure/admin/ViewLogging.jspa (Logging and Profiling)
    • Configure
    • Package name: com.wombatscorp.jira.grouprename
    • Logging Level: TRACE

    Regards, Roman

  2. Daniel Rocha reporter

    Hello, sorry for the delay on answering your request. I attached the generated log just after clicking on rename button.

  3. Daniel Rocha reporter

    Hello Roma,

    I tried again and it still didn’t work. I attached the new log.
    Thanks for the attention

  4. Roma Bubyakin

    Hi Daniel,

    Please try release candidate that should work jira-group-rename-1.2.6.jar

    Thank you for your patient! I’ve rewritten a part of the plugin to fix that w/o bothering you. So it took some time for fixing and testing.

    Regards, Roman

  5. Daniel Rocha reporter

    Hello, Roma.

    Using this new version I was able to change the group name. Thanks for it!

  6. Daniel Rocha reporter

    Hello, Roma.

    Today we faced two problems after renaming that groups we were having problems when we openned this issue:

    • behaviours (from ScriptRunner) based on groups weren’t updated
    • workflows based on groups weren’t updated

    It caused a lots of problems to us today. We had to update a lot of things manually.

  7. Roma Bubyakin

    Hello Daniel,

    Sorry to hear that! I’ll do my best to fill gaps.

    Regarding Behaviours from ScriptRunner

    At the moment plugin covers only core functionality. I have in plans to extend it to as much as possible 3rd parties.

    Will be implemented within Issue#3

    Regarding Workflows

    The only two places that I was able to find in workflows:

    1. Transition > Condition > User Is In Group
    2. Transition > Condition > User Is In Group Custom Field

    It might be some plugin extension. By the way, it should be logged in logs with WARN level.

    Let me know what exactly was missed in your case.

    Regards, Roman

  8. Log in to comment