Printing is not working

Issue #494 resolved
Timo Virtaneva created an issue


I have in my MAC HP DesignJet 120 T with 24" roll paper.

How can I print directly from Valentina? I always get following error message:

QPrintDialog: Cannot be used on non-native printers

I have connected the printer via USB and network.

The pdf printing works fine, but waisting paper.


Comments (68)

  1. Matthias Burkhardt

    I can confirm this, also not working on Ubuntu with HP Designjet 650C. Do you need any information on this ?

  2. Susan Spencer

    I have Linux 64 bit laptop with Ubuntu 14.04, and Brother MFC4820 printer on local network:

    Using test build I saved a layout to tiled PDF I can print it to a Brother printer No error messages

  3. Matthias Burkhardt

    Hi Susan,

    did a try on Linux 16.04 64Bit on the old Designjet 650C. As the plotter is from 1996, it is a bit sensible on the right data.

    I used stable Valentina 0.44. Does it make sense in your opinion to install bleeding edge version?

    Looking forward to work again with valentina after pausing due to time issues!

    Best regards / Saludos Cordiales / Distinti Saluti / Avec mes meilleures salutations / 心想事成,万事如意 / Mit freundlichem Gruß

    Matthias Burkhardt

    Gesendet mit Oneplus One / Cyanogenmod 13 Am 31.05.2016 11:10 vorm. schrieb "Susan Spencer" <

  4. Susan Spencer

    Linux plotting is broken - this is an issue separate from the 'non-native printer' error message from QtPrinter. Cups support for plotters broke sometime last year.

    I run Valentina on Windows to print to my Epson SureColor 44" plotter. (I used to have an HP 650 and those are great plotters!)

    I talked with Hin-tak Lin at Libre Graphics Meeting this year about the broken cups support for plotters. I haven't talked with Till Kampeter yet. It seems that Linux Printing was unaware that a change in cups broke plotter support. This is a big issue.

    The problem with printer drivers is that there are few people in the world who understand them and can support them. So it's difficult to schedule their time to work on something like this. I'm working it.

    But again, the lack of plotter support in Linux Cups is different than the non-native error message generated by Qt.

  5. Roman Telezhynskyi repo owner

    I will try fix it, but only if someone will test it on mac. A virtual machine is not good for this.

  6. Matthias Burkhardt

    Dear Susan,

    thank you for the explanation. I am able to plot with Ubuntu on this plotter, but only if a PDF is exported out of Valentina and the PDF is then printed with Evince. This works solid. Problem is you have to define different paper sizes for every print otherwise paper is waisted. So it is necessary to define many different paper sizes in the Ubuntu Printer dialog. But it works! Native printing from Valentina is unfortunately not working :-/

    Best Regards Buggi

    Best regards / Saludos Cordiales / Distinti Saluti / Avec mes meilleures salutations / 心想事成,万事如意 / Mit freundlichem Gruß

    Matthias Burkhardt

    Gesendet mit Ubuntu 16.04 "Xenial Xerus"

  7. Roman Telezhynskyi repo owner

    Matthias, can you build the last source code from the develop branch and test my patch? If yes, i will publish it immediately.

  8. Susan Spencer

    Matthias, Please check the print size while you do this. Include a test square in your test patterns, I use a 10cmx10cm grid but this is probably overkill, something like 4x4 would work as well.

  9. Susan Spencer

    It's interesting that you can print to your plotter using PDF. MedialLab-Prado reported that the can no longer plot to their Epson SureColor and this happened about the same time that my plotting stopped.

    The change that Linux drivers made last year was to make PDF the native printout format of Linux. So perhaps this may have affected some print drivers but not others?

    The Linux HP 650C drivers stopped supporting the HP 'long format' option several years ago so that I couldn't print anything longer than 54", so I couldn't plot big historical patterns. This is why I bought the Epson SureColor T-7000, which doesn't work at all with Linux anymore!!! :(

    But I really liked the HP 650C better. It's simpler and more sturdy.

  10. Timo Virtaneva reporter


    I'm willing to test, but I don't have a compiling environment. How should I proceed? Are the easy instructions for the compiling environment?


  11. Matthias Burkhardt

    Hi Roman,

    do you have a short introduction on how to get the code to the local HD and compile (this seems to be in the readme, but not how to download the code)? Never worked with bitbucket. I miss the download Zip button from github. I would give it a try tomorrow after work.

    Best regards / Saludos Cordiales / Distinti Saluti / Avec mes meilleures salutations / 心想事成,万事如意 / Mit freundlichem Gruß

    Matthias Burkhardt

    Gesendet mit Ubuntu 16.04 "Xenial Xerus"

  12. Matthias Burkhardt

    Are there any errors reported while you try plotting? The 650C sometimes does nothing, but if all is set the right way this beast plots, not in best quality but so what, we only need to see some kind of line to cut the paper. But if the parameters are set wrong (i.e. Monocolor in the driver) nothing happens. The paper format has to be the right one and color mode has to be set.

    If someone tells me how to get the code to hd, I will try to build and install the patched version.

    Have to relearn it, long ago since I compiled something last time. At least 8 years...

  13. Timo Virtaneva reporter


    Same error message. Not working Only difference is that it goes away with hitting 2 times OK, when the previous version the error message keep coming.

    By the way in this version the Measurement Table edit works.


  14. Timo Virtaneva reporter


    I try to get the Valentina compiled in my MAC, but as usual it will take several iterations to get everything in place.

    It's been a while since I was doing this kind of work and the tools have changed. It would be nice to have a working compiler environment for the MAC version.

    Dou you have a ideas of what should be corrected for these error messages ?

    :-1: error: invalid deployment target for -stdlib=libc++ (requires OS X 10.7 or later) :-1: error: [obj/tape/c++.pch] Error 1

    I have OS X 10.11.5 and latest Xcode


  15. Timo Virtaneva reporter


    That looks good.

    Maybe there could be something about configuring Qt. I have been looking how to configure the QT version control for Mercurial.


  16. Roman Telezhynskyi repo owner

    If you know what to add you can do it yourself, it is Wiki after all. It should be open for editing.

  17. Timo Virtaneva reporter

    Now I can print. However new challenge.

    When I select 24" roll, the dimensions are width 60,96 cm and length 866,99 cm. Everything looks OK on screen, but the print out is 1/3 of the actual size and the printed paper is 60*866 cm

    Scaling is not selected.

    Is the place to see actual size of the document?

    Attached video

  18. Roman Telezhynskyi repo owner

    Everything looks OK on screen, but the print out is 1/3 of the actual size and the printed paper is 60*866 cm

    Sorry, i can't understand what is wrong. Do you get an image that smaller than original?

    Why do you selected to ignore printer fields?

  19. Timo Virtaneva reporter

    I have printed this shirt via PDF and dimensions are correct on the paper.

    With this direct printing all lines are 1/3 of the original. So length of the shirt is 89 cm is 30 cm on the paper. I don't understand what changes the scale.

  20. Timo Virtaneva reporter

    I tested the print->pdf with HP4000 driver with same results. I think the information sent to printer is some how different than the saved pdf.

  21. Matthias Burkhardt

    Ok, managed to build the package. make didn't work, but the good old dpkg-buildpackage did its job like a charm. Said it build 0.4.4, but now is installed. Hopefully with the patches. Unfortunately, printing does not work. Job is completed (no error message from Valentina or system) but no printout. Ubuntu 16.04

  22. Matthias Burkhardt

    The Problem seems to be somwhere else:

    D [02/Jun/2016:20:48:49 +0200] [Job 68] PID 5141 (/usr/lib/cups/filter/foomatic-rip) stopped with status 9.
    D [02/Jun/2016:20:48:49 +0200] [Job 68] Hint: Try setting the LogLevel to "debug" to find out more.
  23. Roman Telezhynskyi repo owner

    Unfortunately this not tell me much. Do you able to print with other applications?

  24. Matthias Burkhardt

    PDF printing out of Evince is working. So if a PDF is made first and the PDF is printed it works (with certain printing parameters). Direct printing from Valentina did not work up to now. Maybe the paper format is the problem, not sure.

  25. Roman Telezhynskyi repo owner

    The printed version is not complete. There is little missing in the end.

    I see i will try another way.

  26. Roman Telezhynskyi repo owner

    Maybe the paper format is the problem, not sure.

    I also don't know. Do you have any Qt based application you can check? What OS do you use?

  27. Timo Virtaneva reporter

    The tiled print is not very informative, because it is just one A4 page. If I use bigger page, it's like normal print. The MAC pdf print is just a save feature in the printer dialog. It is not printing the document trough a PDF printer like Windows and Linux

  28. Roman Telezhynskyi repo owner

    The tiled print is not very informative, because it is just one A4 page.


  29. Roman Telezhynskyi repo owner

    Okay, i think i know what is wrong. An image is too big for QImage class. Tomorrow i will busy, so i will return to this bug as soon as possible.

  30. Timo Virtaneva reporter

    I tried by leaving one piece away (the short sleeve) and everything printed OK. I looks a size issue

  31. Roman Telezhynskyi repo owner

    Good. I see a way to make printing without QImage. But it will need some code redesign.

  32. Timo Virtaneva reporter

    I wanted to print just few small pieces, but the printing went wild

    Here are 2 saved pdf's with equal settings. Paper size is 60.96*100 cm. The only difference is that in the OK version, there is also a sleeve. In the scale_wrong version are just the small pieces. The scale and paper orientation are weird in the pdf. I have also printed both versions on the paper and the result is the same as in the pdf.

  33. Roman Telezhynskyi repo owner

    Timo, thank you for your help. Don't worry i see your posts, but i still busy and can't begin working with this bug.

  34. Roman Telezhynskyi repo owner

    Redesign printing system. ref #494. Printing is not working.

    Made complete redesign of printing code. Now the code check printer's dpi and calculate scale factor. Instead of printing with QImage buffer the code print directly on printer. Help avoid limitations of QImage class.

    Also removed menu option "Save as PDF". The option duplicate option "Export As" and also mislead a user about purpose of option "Print preview".

    → <<cset 148506c27c6d>>

  35. Timo Virtaneva reporter

    No I didn't but it work better than the previous version. It paginating and handling the paper size correctly.

    I will have more test, when I have real patterns to print. The roll is just 30 m, so I don't like waist too much.

    So far it works fine.

  36. Log in to comment