Jigit Stopped Reindexing After Upgrading it to Version 1.2.15

Issue #92 resolved
Abid Raza created an issue


We have configured multiple repositories in our Jira using Jigit Plugin. Unfortunately, I updated the plugin some day and it stopped the indexing. I have tried to re-index the repository but it is showing 0 checkin.

We are using Jira 7.9.2 Version. Could you please let me know what is causing this issue and how can I fix this issue?



Comments (30)

  1. Dmitrii Apanasevich repo owner

    Hi Abid,

    Could you check Jira logs to find any information related to Jigit?

  2. Abid Raza reporter

    2019-10-03 08:35:44,021 jigit-indexer-1 ERROR ServiceRunner [jigit.indexer.JigitIndexer] Couldn't index repo: Repo-Name
    api.APIException: {"message":"403 Forbidden - User is blocked"}

    I am not sure which user it is referring to?

  3. Dmitrii Apanasevich repo owner

    I am not sure which user it is referring to?

    I would assume, that it was the user which Access Token is specified in setting, but you said that Test connection works fine.

    It could be also a network issue. Try to call GitLab API via curl. Something like this:

    curl -i --header "PRIVATE-TOKEN: {YOUR_SECRET_TOKEN}" "http://my-gitlab-url/api/v4/projects/Repo-Name/repository/branches/master"

    You can also search for extra curl examples here in the issue tracker.

    It’s definitely not a Jigit isssue.

  4. Fabian Girrbach


    I would not be so sure that this is not an issue of the plugin itself.

    We did install version 1.2.12 first and we experienced some issues with the order of comment messages but all the repos and branches were indexed and showed the corresponding commit information.

    Since upgrading to version 1.2.15, some repositories are ignored and show therefore no related commit information. We first tried re-indexing, afterward removing and adding the Gitlab group. But in the end, we ended up with the same situation that for some repos we have the commit history for some we don’t, and for some Jigit is not including the most recent changes.

    I also had a look at the log files but a search in all the log files of the log folder for “jigit“ did not return any hits.

  5. Abid Raza reporter

    My concern is when it says “Connection is OK” then it should re-index. There is no network related issue between the servers.

    Could you please schedule any remote session to troubleshoot this issue. I am not sure but the last change I made was updating the Jigit Plugin and That’s it.

    Please help.


  6. Abid Raza reporter

    Hi, Can someone please help me here. I need to fix this issue at earliest? It would be really appreciated if someone can contact me to resolve this issue.


  7. Dmitrii Apanasevich repo owner

    Have you tried to call GitLab API via curl?

    BTW, if you so confident that the cause is the newest version of the add-on, then just install the previous one.

  8. Dmitrii Apanasevich repo owner

    Hi Fabian,

    There were no changes made to indexing mechanics since 1.2.12. Look at commits into source code.

    I also had a look at the log files but a search in all the log files of the log folder for “jigit“ did not return any hits.

    That's not enough. Please, follow the advice from issue 91 and enable INFO logging level. Your case differs from the case of the OP.

  9. Fabian Girrbach

    Thanks … I just did this and I will get back to you.

    But already thanks for writing such a nice plugin.

  10. Abid Raza reporter

    I have run the curl request and it successfully run on Jira Server. Looks like Jigit indexer is not running in background. I can not see logs when I run indexing the repository through Jigit Plugin.

  11. Alexander Schüßler

    Hi @Dmitrii Apanasevich

    I can also confirm the issue as of our upgrade to Jira 8.5.0 Enterprise.
    I also updated Jigit to 1.2.15 and found new commits no longer being populated into the issue even after a reindex.

    Note: As I rolled back the update of Jigit to 1.2.14 and reindexed the repository again the commits I missed before nearly instantly got displayed in my issue (I actually commited pom.xml and maven update for my Scriptrunner project as of the internal issue I have for upgrading JIRA).

    So I guess there must indeed be something have turned wrong in your latest version.

    Can I help you somehow? I can check logs or maybe update Jigit on my test system again and do some testing + providing logs.

  12. Abid Raza reporter

    @Dmitrii Apanasevich - It looks like a bug in the new version. Could you please identify the issue and fix it at your earliest and this is causing serious issues and we can not see checkins using Jigit Plugin.

    Your quick response would be highly obliged.

  13. Paul Norrod

    In our instance (jira 8.5, but also in 8.3.4) we noticed as well that new commit messages no longer show up. For us it seems jigit is retrieving the same commit id’s over and over again in the httpd logs in gitlab for just 2 of the couple of dozens of repo’s we have configured and it does not seem to get passed this. We downgraded to jigit 1.2.14 now, but we also had to disable these 2 repo’s to get it to index the other repo’s again.

    So something is going on here, either due to changes in newer Jira versions (8.3.4 seems to have the issue already) or maybe latest jigit, maybe even combination of both.

    As soon as I can find the time to dive into this further I will enable jigit info loggin in Jira and see what that comes up with, but just wanted to give a heads up that on our setup we seem to have similar issues like this and possibly #91.

  14. Abid Raza reporter

    I think there are multiple users who are facing the same issue therefore it must be a bug in the new version. Have you guys started working on fixing this issue?

  15. Ken Netzorg

    I concur with the issue. I just downgraded to 1.2.14 on my Jira 8.5 instance and indexing returned. I admit I didn’t do any Jira log review or further troubleshooting, just took the quick path to get it working again. I did see that the API on the GitLab server was being hit for the first project configured but even then, it wasn’t increasing the commit count in Jira.

  16. Dmitrii Apanasevich repo owner


    So the workaround is to install the previous version 1.2.14.

    Can I help you somehow? I can check logs or maybe update Jigit on my test system again and do some testing + providing logs.

    @Alexander Schüßler that would be great! What I need are Jira log records related to Jigit. Please, enable DEBUG logging level for package jigit for 10 minutes and than gather log records.

  17. Fabian Girrbach

    Hey @Dmitrii Apanasevich,

    Just a small remark … I enabled logging for ‘jigit'' with INFO level but the logs still do not show any hits. Probably I am doing something wrong.
    Maybe a detailed explanation of how to help you with logging information and where to find the logged information could be a useful addition to the wiki section.

  18. Dmitrii Apanasevich repo owner

    Looks like I’ve found the cause. Please, wait for the fixed version. I’ll provide it ASAP.

  19. Alexander Schüßler

    Hi @Dmitrii Apanasevich ,

    I saw at work that you are already on a fix..let me know if you still want me to investigate on my side.

  20. Dmitrii Apanasevich repo owner

    Hi Abid,

    There are no estimates. It’s not a “Programmer Tycoon“ it’s free add-on under Apache 2.0 license. You use it on your own risk with no warranties. Consider it as gift. I don't owe anything to anybody.

    You can fix the issue yourself because code is open, or get back to version 1.2.14, or patiently wait for the fix.

    I feel your pain guys. I work on the problem as much as I can.

  21. Dmitrii Apanasevich repo owner

    The new version is on the Marketplace. Please let me know if everything is ok now.

  22. Ken Netzorg

    I updated to 1.2.16 and issued a re-index that successfully completed. Appears to have worked and will keep an eye on it through the week as activities occur.

    Thanks for the quick turn-around!

  23. Alexander Schüßler

    Hi there,

    the issue appears fixed in Jira 8.5.1 with Jigit 1.2.16 as well.
    Thanks for working on this fix.

  24. Log in to comment