Minimum python version for flower and therefore 0.9.0

Issue #747 resolved
Ed McDonagh created an issue

Flower depends on Tornado which requires an up to date SSL module which requires Python 2.7.9 or later.

Need to add to docs some guidance as to how to upgrade Python if older than 2.7.9.

A good first step would be to check with python -V

Also, flower requires a more recent version of setuptools than some users may be using (v3.6 is too old, I don't know what the minimum version is).

Can be fixed with pip install setuptools -U

For Ubuntu users,

  • Trusty/14.04LTS would be tool old (Python 2.7.5)
  • Xenial/16.04LTS and later would be ok (Python 2.7.11 and later)

Marking as 0.9.1, but needs to go in the 0.9.0 documentation too.

Comments (7)

  1. Log in to comment